Degraded user summarizations and Gemini 2.5 Flash

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 26, 2026 - 19:07 UTC

Investigating

We are investigating a service degradation affecting Gemini 2.5 Flash and user summarizations.
Posted May 26, 2026 - 18:07 UTC
This incident affected: Cloud Agents and IDE.