Service Degradation - Agent Chat

Incident Report for Cursor

Resolved

The incident is now resolved.
Posted Oct 22, 2025 - 22:00 UTC

Monitoring

Chat functionality has been restored and service is recovering quickly for all users. The team will continue to monitor for any further issues closely.
Posted Oct 22, 2025 - 21:00 UTC

Identified

We are investigating a widespread issue causing chat to be unavailable for most users.
Our team is actively working on a fix and will update this page as soon as we have more information.
Posted Oct 22, 2025 - 20:48 UTC

Update

Cursor features are currently degraded - the team is investigating.
Posted Oct 22, 2025 - 20:45 UTC

Investigating

We are receiving reports that Cursor's chat is failing for some users.
Posted Oct 22, 2025 - 20:42 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes) and Cloud Agent (Infrastructure).