Cloud Agents degraded due to third-party outage

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 22:20 UTC

Investigating

Cloud Agents are unable to start due to an ongoing Github issue.
Normal function will resume automatically once Github's issue is resolved.
For updates, see https://www.githubstatus.com/incidents/5q7nmlxz30sk
Posted Nov 18, 2025 - 20:48 UTC
This incident affected: Cloud Agent (Infrastructure, Slack Integration).