Composer 2.5 Fast Service Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 24, 2026 - 18:49 UTC

Investigating

We are investigating a service degradation on Composer 2.5 Fast.
Posted May 24, 2026 - 17:41 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.