Investigating Elevated Cursor Grok 4.5 Errors

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 00:45 UTC

Investigating

We are investigating a service degradation affecting IDE & Cursor Grok 4.5
Posted Jul 28, 2026 - 00:34 UTC
This incident affected: IDE.