Indexing - Service Degredation

Incident Report for Cursor

Resolved

Codebase indexing should now be fully operational for all users.
We are monitoring the situation to ensure no further degradation occurs.
Posted Apr 01, 2025 - 09:15 UTC

Identified

Due to unforeseen issues, Cursor's codebase indexing is currently severely degraded.
We have escalated this to our service providers and hope to have a fix deployed soon.
Posted Apr 01, 2025 - 07:41 UTC
This incident affected: Cursor App (Codebase Indexing).