Upstream Service Degradation - Codebase Search
Incident Report for Cursor
Resolved
OpenAI has resolved the issue.
Posted Dec 12, 2024 - 05:00 UTC
Monitoring
OpenAI are working on a fix, and we are awaiting this to be deployed, and OpenAI services to begin restoring to normal.
Posted Dec 12, 2024 - 00:27 UTC
Identified
Due to an upstream issue with OpenAI (tracked at status.openai.com), OpenAI-hosted models are currently unavailable.
Additionally, Cursor's codebase search functionality is also not available.

As a result:
- OpenAI based models, like GPT-4o and GPT-4o-mini will not respond
- Codebase search may not function correctly
- The Composer Agent is temporarily unable to use the codebase search tool

We apologize for any inconvenience and appreciate your patience.
Posted Dec 12, 2024 - 00:13 UTC
This incident affected: Cursor.