Marketplace Search is Degraded

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 19:40 UTC

Investigating

We are investigating this issue.
Posted Jul 03, 2025 - 18:21 UTC