Degraded Services - Codebase Indexes
Incident Report for Cursor
Resolved
OpenAI have deployed and are monitoring a fix, but we are confident Cursor's codebase indexing has returned to full functionality.
For any further issues, please post on forum.cursor.com
Posted Jan 21, 2025 - 20:00 UTC
Update
We are observing a gradual return to full function in the codebase indexing within Cursor.
Posted Jan 21, 2025 - 18:00 UTC
Monitoring
Due to an ongoing issue with OpenAI's Embeddings, we are currently seeing issues with the following features:
- Codebase Wide-Search - Codebase-wide search will be unavailable during this time
- Agent - The agent's semantic search tool will not execute
- Codebase Indexing - Indexes will be inaccessible

Further details can be found at https://status.openai.com
Posted Jan 21, 2025 - 13:30 UTC
This incident affected: Cursor.