Background Agent Service Degradation

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 17:30 UTC

Monitoring

A fix has been implemented and is being deployed to all users.
The incident will be closed once the deployment is fully propagated.
Posted Sep 09, 2025 - 17:07 UTC

Identified

The issue has been identified, and a fix is in progress.
A further update will be issued once a fix is deployed.
Posted Sep 09, 2025 - 16:52 UTC

Investigating

We are currently aware of an issue regarding Background Agents being unavailable in Slack.
During this time, users may see errors about not having write access to their repositories.
Posted Sep 09, 2025 - 16:49 UTC
This incident affected: Background Agent (Slack Integration).