Investigating Composer degradation

Incident Report for Cursor

Update

We are continuing to investigate this issue and will provide updates as more information becomes available.
Posted Jul 29, 2026 - 09:57 UTC

Update

We have resolved the service degradation with Grok 4.5 and are still investigating the degradation with Composer 2.5.
Posted Jul 29, 2026 - 09:11 UTC

Investigating

We are investigating a service degradation with Grok 4.5 and Composer 2.5
Posted Jul 29, 2026 - 08:51 UTC
This incident affects: Automations, Bugbot, CLI, Cloud Agents, and IDE.