Investigating service degradation - Grok 4.7

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 20:36 UTC

Monitoring

A fix has been implemented and we are monitoring for service restoration.
Posted Sep 23, 2026 - 20:31 UTC

Investigating

We are investigating degraded performance for requests that use Grok 4.7.
Posted Sep 23, 2026 - 20:28 UTC
This incident affected: Automations, CLI, Cloud Agents, and IDE.