Degraded Performance for Cloud Agents, Automations & Security Agents

Incident Report for Cursor

Resolved

This incident has been resolved.
Posted May 19, 2026 - 05:15 UTC

Monitoring

A fix has been implemented and we are working toward recovery
Posted May 19, 2026 - 05:09 UTC

Identified

The root cause has been identified and a fix is being implemented.
Posted May 19, 2026 - 04:09 UTC

Update

We are continuing to investigate this issue. We will provide updates as more information becomes available.
Posted May 19, 2026 - 03:25 UTC

Update

We are currently investigating this issue. We will provide updates as more information becomes available.
Posted May 19, 2026 - 02:57 UTC

Investigating

We are investigating a service degradation affecting Cloud Agents.
Posted May 19, 2026 - 01:48 UTC
This incident affected: Automations and Cloud Agents.