Anthropic Rate Limiting

Incident Report for Cursor

Resolved

We have implemented a series of mitigations, and should start to see usage return to normal.
For any further issues, let us know at forum.cursor.com
Posted Feb 28, 2025 - 20:59 UTC

Monitoring

With the release of Claude 3.7, demand to try the new model is currently causing some rate-limiting issues, where users may see connection errors when attempting to use Claude models. To help mitigate this high demand, we have temporarily removed Claude 3.7 from free trial and slow pool users, while we resolve the usage issues.
Posted Feb 25, 2025 - 16:47 UTC
This incident affected: Cursor App (Chat - Agent & Custom Modes).